IP 190 UNABLE TO ESTABLISH SESSION - PROCESS FAILED WITH SENSE 00004002.

Topics: Developer Forum, User Forum
Aug 4, 2011 at 1:57 PM

Hi,

I am trying to use this library in a windows form application.

Well, i am able to launch my mainframe application(H30-7060-Z/OS 1.4 Application) on the form. when i enter application sign-on "TSO" then it takes me to next screen which asks for UserID. My problem starts from here.

Again, if i enter User ID then it takes me to next screen on which , i am getting an error message "IP 190 UNABLE TO ESTABLISH SESSION - PROCESS FAILED WITH SENSE 00004002."

Moreover, i am new to mainframes. So, can anybody tell me how to find the protocol which a mainframe application uses or what is this error about?

Thanks,

NY

Aug 4, 2011 at 2:09 PM

I am trying to connect to inhouse Mainframe application . So, you are not able to connect to it.

Please someone help me on this. Its a do or die situation for me.

 

Aug 4, 2011 at 2:49 PM

Have you tried build 55326?  There seems to be a problem with the latest build... not sure about the ones in between.  It seems to be a telnet issue.  My Cics app will not accept connections from the latest build.  I think it's a telnet bug, or at least that is what the error I'm getting back leads me to believe.

I would love to fix the bugs in this project, but that is going to take some time.  I'm not overly familiar with the telnet protocol internals or tn3270 protocol, but I'm researching it right now.

X

Dec 21, 2011 at 10:10 AM

I'd have the same problem and I'd try 55324 crish's branch, it's work perfectly.

Mar 7, 2013 at 7:58 PM
I got the same error, but only when connecting using LUs, when i connect directly (only ip and port) , there´s no error
gonna try these two builds...
Mar 11, 2013 at 8:38 PM
I´ve made some tests and the versions that works are: 55324 (CodePlex and Chris) and 55326 (CodePlex and Chris).
Hope this help anyone in trouble....
Developer
Aug 1, 2013 at 7:29 PM
Edited Aug 1, 2013 at 7:29 PM
I went through all of the changes, and found that the following lines (around line 2100) in Telnet.cs were causing the issue.
if ((e_funcs & E_OPT(TN3270E_FUNC_RESPONSES)) != 0)  
    h.response_flag = TN3270E_HEADER.TN3270E_RSF_ALWAYS_RESPONSE;
else
Comment those out, and you shouldn't see the 00004002 error anymore, but still have the other improvements. I also found a bug in the keyboard action. Is the coordinator still involved in this project? It would be nice to get all of the branches merged back into the trunk. It's getting messy.